Atualização Estável 2021-07-13

Mais uma atualização para o ramo estável foi liberada, e como vocês costumam dizer, essa é “grandinha, gigante, enorme, bitela”. Essa atualização é maior pelo fato de ter acontecido 3 atualizações no ramo checking out antes dos pacotes serem liberados para o ramo estável, corrigindo alguns problemas informados pelos usuários que utilizam o ramo checking out.

Abaixo nós deixaremos as informações básicas sobre o que foi atualizado, sobre os erros conhecidos (pode ser alterado com o passar do dia), e a forma de como atualizar o sistema (seguindo as informações do fórum). Se você utiliza o repositório do weblog, pedimos que aguardem ao menos 24 horas para atualizar o sistema, esse pace garante que as atualizações dos nossos pacotes já estejam nos servidores.

Principais atualizações

  • A maioria de nossos Kernels foram atualizados
  • Mesa está agora em 21.1.4
  • Com o motive force Beta da Nvidia mais recente , os problemas com DisplayPort foram corrigidos: (*10*)470.42.01
  • O KDE Framework foi atualizado para 5.84.0
  • O KDE Equipment está agora em 21.04.3
  • O KDE Plasma foi atualizado para 5.22.3
  • O Gnome foi atualizado para 40.3
  • O Wine está agora às 6.12
  • O ZFS foi atualizado para 2.1.0
  • O Pipewire foi atualizado para (*12*)0.3.31
  • O Firefox está em (*19*)89.0.2
  • Atualizamos Cutefish para (*16*)0.3 e fornecer um (*14*)novo meio de instalação para experimentá-lo
  • Atualizamos o Pamac para funcionar com o Pacman 6.0
  • ALSA obteve as atualizações necessárias para funcionar melhor com o Pipewire
  • LibreOffice está agora em 7.1.4
  • Alguns dos navegadores foram atualizados
  • Cinnamon foi atualizado para (*9*)5.0
  • Deepin recebeu algumas novas atualizações
  • Mais atualizações do KDE-Git e Deepin
  • Outras atualizações regulares de upstream, incluindo python e haskell

Essa foi a lista dos pacotes que o pessoal mais aguarda as informações, se você deseja ver a lista completa, (*11*)clique aqui.

Kernels Suportados pelo Manjaro

  • linux44 4.4.275
  • linux49 4.9.275
  • linux414 4.14.239
  • linux419 4.19.197
  • linux54 5.4.131
  • linux510 5.10.49
  • linux512 5.12.16
  • linux513 5.13.1
  • linux514 5.14-rc1
  • linux510-rt 5.10.35_rt39
  • linux511-rt 5.11.4_rt11

Problemas conhecidos e soluções

Você pode ser bloqueado ao atualizar utilizando o Pacman devido a alguns pacotes libcanberra . É recomendado usar o Pamac para fazer a atualização, normalmente ele corrige esses problemas automaticamente. Abaixo terá mais informações de como proceder.

Pacotes Compiz como (*8*)compiz-easy-patch foram retirados de nossos repositórios. Devido à atualização do protobuf, você pode precisar reconstruir esse pacote localmente no seu ultimate. (*13*)Compiz-easy-patch removido dos repositórios.

Se você encontrar qualquer outro problema, verifique na sessão de problemas antigos (*5*)clicando aqui.

Atualizando o sistema

Antes de utilizar o Pamac na sua forma gráfica ou pelo terminal, o correto a se fazer é classificar os espelhos e só depois atualizar o sistema, você pode conferir o nosso artigo explicando como se fazer isso. E para ter certeza que o espelho mais rápido já está totalmente sincronizado e com as novas atualizações, clique aqui e verifique na página de standing.

Após classificar os espelhos, você pode atualizar o seu sistema através da interface gráfica do Pamac, mas recomendamos a utilização do terminal (já que o próprio Pamac será atualizado). Outra recomendação nossa é, atualize primeiro somente os pacotes dos repositório (se você utiliza o do weblog, lembre-se de aguardar ao menos 24 horas), e só depois atualize os pacotes provenientes da AUR.

Comando para atualizar somente os pacotes presentes em repositórios, os pacotes da AUR não serão atualizados.

pamac replace --force-refresh --no-aur

Se você encontrar o problema mencionado com os pacotes libcanberra, make the most of o comando abaixo para remove-los e tente o comando acima novamente.

pamac eliminate lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer

Seguindo as informações acima, provavelmente você não terá maiores problemas. Verifique as informações do progresso da atualização, muitos usuários atualizam o sistema e não olham se existem mensagens de erros, ai eles reiniciam o sistema e shabum!!!

Quando acontece do sistema não iniciar, ai a maioria corre para um fórum para criar um tópico com o titulo “O Manjaro quebrou após a atualização”, ou, “O Manjaro quebrou do nada”. Existem as exceções, mas normalmente é de usuário que utiliza uma distribuição Rolling Unlock e não checa as informações antes, durante ou depois do processo de atualização.

Problemas com pacotes da AUR

Após uma atualização do Manjaro, é comum que alguns pacotes instalados da AUR parem de funcionar. Normalmente isso acontece com pacote realmente compilados (aqueles que demoram mais pace e fica passando muitas letrinhas sobre o que está sendo feito), e para corrigir, você precisará recompilar o pacote do próprio programa ou de alguma dependência que ele actual que também foi instalada da AUR.

Nós fazemos esse processo de re-compilar nos pacotes do nosso repositório, e por isso que recomendamos que o usuário aguarde ao menos 24 horas. Assim ele atualizará o sistema e os pacotes que disponibilizamos e não encontrará problemas, se for ansioso, atualizará o sistema antes e terá problemas com os pacotes do nosso repositório, mas isso será por causa da ansiedade dele, já que as nossas atualizações provavelmente ainda não estavam disponíveis.

Ainda não consigo atualizar

Se você seguiu as informações e ainda não consegue atualizar o sistema, tenha certeza que verificou as informações dos (*4*)problemas antigos. Você pode entrar em nosso grupo no telegram para que possamos lhe ajudar com o problema, mas verifique se as informações não estão listadas nos problemas antigos.

Confira se o seu problema não foi adicionado ao artigo posteriormente, nos estaremos editando o artigo conforme as informações vão aparecendo no fórum ((*6*)clique aqui e confira o tópico no fórum). Não cole o erro nos comentários, além de normalmente não conter informações importantes, só demostra o quanto você é preguiçoso (e o comentário será apagado).


(*1*)

Caso algum programa que você goste ainda não tenha uma versão para Manjaro, por prefer, escreva nos comentários o nome do programa que iremos procurar por algum equivalente ou, se possível a portabilidade para Manjaro, entraremos em contato com desenvolvedores.

Por prefer, não deixe de compartilhar nas redes sociais as publicações deste weblog, pois nosso incentivo para produzir um conteúdo bacana é saber que estamos ajudando pessoas a conhecer cada vez mais as funcionalidades dessa maravilhosa distro Linux.

Nos acompanhe: